Pool API and Website Hashrate Statistics Delayed

Incident Report for Foundry USA Pool

Resolved

This incident has been resolved. All hashrate statistics have been back filled and up to date on a move forward basis.
Posted Nov 18, 2025 - 18:56 UTC

Identified

The Foundry USA Pool Website and API are experiencing delayed hashrate statistics. We have identified the issue and expect the data to backfill within the next 30 minutes.
Posted Nov 18, 2025 - 18:16 UTC
This incident affected: Pool Website and API Server.